0

After giving the command ./configure, it is showing that:

pQserverversion in -lpq not found. configure: error: could not find libpq.

What does it mean?

I am installing PostGIS 1.5 using Red hat Linux (32 bit) version 5.3. PostgreSQL version 8.3.

  • Could you elaborate a bit? What are you trying to do? What data do you have? etc – Martin Sep 16 '14 at 8:40
  • 1
    ... and why the ancient PostgreSQL, RHEL and PostGIS? You shouldn't be doing anything new at all on a system that old, it should be in maintenance mode while you work on an upgrade. – Craig Ringer Sep 16 '14 at 8:58
1

I agree with Craig. Your redhat version is very old. Any way, the problem is that you need the package libpq-dev installed.

yum install libpq-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.