1

I have a shapefile to which I joined two tables from a MySql database. I used one column of the first table to color the polygons in my shapefile which works fine. Three columns out of the second table should now be used to produce a pie chart on top. I can easily select those features, so the join worked. However, no pie chart is drawn. "Display diagrams" is checked. I tried the following so far:

  1. Change diagram type (Did not work)
  2. Try to display a value from the first table instead of the desired table. (Did not work)
  3. Changing the priority from low to high. (Did not work)
  4. Delete the first table.(Did not work) QGIS is not drawing anything.

The log for errors and warnings are completely empty. Does anyone has an idea? Thanks in advance.

1

I've been faced with a similar bug using QGIS v2.6, and have been googling round to no avail. For some reason the pie wouldn't display.

I found a way to get it working through trial and error by switching on a blank label (''). Don't know why this worked but the diagram seems to be displaying fine when the label is switched on, then it disappears when the label is switched off.

Hope that helps, 9 months on from your post!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.