1

Background:

I am currently working on a project that requires me to translate shapefiles into GeoJSON format and then upload them into MongoDB. There is a problem with MongoDB that prevents it from properly handling geometries which have overlapping/intersecting nodes (points). In many cases I was able to use QGIS to scan for, and fix, geometry errors (particularly if there were few of them since I was relying on manually fixing these with the node tool). However I now have a shapefile that doesn't actually register any errors when I use QGIS -> Vector -> Check Geometry Validity tool, yet it clearly contains points that intersect.

What I've tried:

I admit I am new to using QGIS. I am working with QGIS 2.4 on Arch Linux and I have installed the GRASS package (grass64). I have tried using v.clean command with a variety of options including break and bpol options, yet each time I run that it outputs two new layers (a Cleaned layer and an Errors layer). The Cleaned layer shows up blank, and the errors layer always just shows this single triangle geometry. (see link at bottom of post for reference)

Is there something I can do in terms of settings or different tools/plugins to achieve what I want?

Ultimately what I need to do is separate those corners/points from each other so that >< would become > <. Sorry if this wasn't explained clearly, I hope the images can provide more information to clarify.

Images for reference

1

I seem to have solved my own issue after spending far too long researching this problem and finally just trying about every option available in QGIS in hopes that one would work out. The solution that worked for me here was to select from the menu in QGIS: Vector -> GeoProcessing Tools -> Buffer(s). I will mess with the settings here to fine tune it to my needs but my initial run used the following options: Segments to approx. = 5 Buffer Distance = 0.0001 Output Shapefile = [whatever you want] Add result to canvas = true (for convenience really)

The result was to separate apart all of my joined/intersected nodes with a very small space. Of course this can cause some issues depending on your dataset and your specific requirements for precision, but I figured I would add this info here for anyone else who may struggle with a similar problem in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.