1

I have a data capture map in ArcGIS Collector working correctly on a Samsung Galaxy Note 8 (Android 4.1.2) and a Samsung Galaxy Tab 4 (Android 4.4.2). I also have the same map working in the ArcGIS app on a Nokia Lumia 1020 (Windows Phone 8.1 Update 1).

The Tab 4 is having problems syncing. I enabled offline editing as we have an ArcGIS Server 10.2.2, and I had performed several tests with the devices with a few features at the time. The Tab 4 is currently in an East African country, where the internet (Wifi, 3G) is not always great.

I at first thought it was the unstable internet connection which caused the sync to fail, as even though the tablet had an internet connection, it would still not sync. My colleague was also unable to download a new web map I set up for him, even though he could see the online list of maps in the app.

I came across this thread on Geonet, where it seems to indicate that the size of the upload, it if it includes attachments, can cause problems.This seems to defeat the purpose of using Collector for offline editing. The workflow was: Capture features during the day -> Sync the tablet at night when connected to Wifi. The number of features would be at least 20, all with at least one attachment. After reading the Esri thread though, that complicates the issue.

I'd like to know if anyone has a workaround for this. Normally we would have set up an ArcGIS Mobile device for completely disconnected editing and synced it when they returned, but we were hoping to move forward with Collector so we could check daily progress. I would also like to know how widespread the problem is (batch upload of features with attachments failing).

  • I found that enabling editor tracking makes upload behaves strangely at times – FelixIP Sep 20 '14 at 0:56
  • I am having the same issue on a Sony Android tablet. I have tried it with both Wifi and phone connection. It will work for 1-5 features but more than that and the sync process just hangs for a few hours and then finally fails. Our Mobile GIS isn't working since upgrading to 10.2.2 so disconnected editing is near impossible at the moment. Not happy. – user40913 Nov 21 '14 at 4:23
  • Welcome to GIS SE! Some of our protocols can take a little getting used to. One of them is that the answer area into which you have made a comment is reserved for direct answers to questions. I'll convert it to a comment but if there are some points of difference between your issue and that described then you want to consider asking a new question. – PolyGeo Nov 21 '14 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.