4

I have an issue saving a set of polygons as a new layer that I've selected using the polygon select tool in QGIS.

After selecting the polygons in the main (source) layer, I've tried two ways:

  1. I tried Edit> copy features > paste features as new vector layer. After which I get the dialog box below. A also tried paste features as new memory vector layer - which created a layer, but there were no attributes in the table - is was empty

enter image description here

  1. I tried another way of right clicking the selected layer > save as > save as > and clicked the 'save selection only' in the 'save vector layer as...' dialog box. I got the same dialog box.

Any ideas welcome.

  • If you select 'Vector|Geometry Tools|Check geometry', select the vector layer and click 'ok', do you get errors in the geometry? – Simbamangu Sep 20 '14 at 8:10
  • I've been having the same problem in QGIS 2.18 for windows. I've tried in on several different layers and get the same error message for each. – lepula Mar 3 '17 at 14:46
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – ArMoraer Mar 3 '17 at 15:19
  • In my case problem was file size. Split it up and problem solved – Coldon May 23 '17 at 14:05
4

Another method which I don't think you mentioned is to first create a new polygon shapefile:

Layer > New > New Shapefile Layer...

Then select Polygon in the options and click OK. Toggle the Edit button for both the new layer and the layer you want to copy the polygons from.

Editing icon

Copy your polygons and paste them into the new shapefile. If there are no errors then the polygons along with their associated attributes should be copied.

2

Although I'm not sure if it's the same, I had a similar problem in QGIS a couple of months ago. For me it was due to the polygon geometry becoming corrupt. One of the inner rings didn't close and so QGIS recognized the geometry as invalid but didn't tell me in a way I understood.

I ended up using a Repair Geometry tool in ArcGIS which did a great job, but you might not have access to it.

I found this post from a guy who did the same thing with QGIS, Grass and GDAL. I hope it helps...

0

I had this error when right clicking a layer and trying to save current selection with the 'Save only selected features' box.

The answer for me was to click the "Browse" button next to the "Save as" input, navigate to my project files, and then save the file. It seemed to be an issue with QGIS trying to save the file in an operating system default user location and then losing the file since my project was referencing files with relative paths.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.