2

I'm trying to dissolve polygons based on a code number in the attribute table.

It all works well, with an exception of two polygons that fail to dissolve - they literally drop out from the output. It affects always the same two polygons. The dissolve process is successful, the layer is generated, just with two holes in it. ArcGIS does not give me any error message or anything.

I have tried messing with the source dbf file to see whether there are perhaps some funky characters in the code field, but it seems to be fine. The code is really just a simple number (12 and 707 specifically).

The only thing that seems to have perhaps some relevance is that both of those missing polygons happen to be parts of large cities, therefore they consist of higher number of small polygons to be dissolved (but still nothing that ArcGIS could not handle). Other than that I have really zero clue what could be wrong...

I'm using ArcGIS Desktop 9.3.

1

For symptoms like these in shapefiles, or feature classes (of file or personal geodatabases), and as you have noted in a comment, the tool to use is Repair Geometry (Data Management) which is available at all license levels:

Inspects each feature's geometry for problems and fixes the problems that are found.

The Clean tool mentioned in the other answer is for Coverage format only, requires an ArcInfo level license, and is really just a wrapper around the CLEAN command of ArcInfo Workstation . Although Coverages still have some support in ArcGIS Desktop I think it very unlikely that you would be using them in preference to file geodatabases or shapefiles for local spatial data storage.

3

It's likely the result of a topological error in the original vector file. If borders don't align perfectly, and remember that in most vector formats coordinates are stored to a very high level of precision, then errors will result in the dissolve output. This is the most common problem when running Dissolve operations. They can usually be fixed with a 'Vector Cleaning' tool. In ArcGIS, the tool that performs vector topological corrections is called Repair Geometry. In the map below, I've performed a Dissolve operation on a (not so accurate) world map to create a landmasses layer. Notice how the borders around Mongolia and parts of China are still present after the Dissolve? I then ran Vector Cleaning to fix the topological error and re-ran Dissolve. Those spurious borders are now gone.

enter image description here

enter image description here

  • Thanks for pointing that out. I suspect there might be the problem as those problematic parts were actually created in a bit different fashion than others and some of them show what you describe. However Clean seems to be a version 10.0 tool. Can you think of a way how to do this in 9.3? – pulzaar Sep 20 '14 at 18:08
  • @pulzaar Let us know if the vector cleaning works for you. Good luck. – WhiteboxDev Sep 20 '14 at 18:10
  • Great, using the 9.3 version, running simple Repair Geometry solved the problem! – pulzaar Sep 20 '14 at 18:27
  • @pulzaar Wonderful, I'm glad it worked for you. – WhiteboxDev Sep 20 '14 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.