2

I have created a map and made a nice lay-out in the printer composer (in QGIS 2.4), the weird thing is, that if I try to save my map as an image or as a pdf immediately after entering the name in the "save as-dialog box" my map disappears from the composer interface, and then it is nowhere to be found. Luckily I did save the template, and only after restarting QGIS can I load the template again.

I don't understand what is going on here and would be very happy if someone can tell me this.

  • 1
    Perhaps a bug? I use 2.2 and it seems to work fine, nothing disappears and can save as an image, pdf etc. – Joseph Sep 22 '14 at 14:32
  • 1
    Could you specify what operating system you are running: Linux, windows, OSX? – mace Sep 22 '14 at 15:11
  • Windows 8. And I just found out where the problem is. Just not how to solve it. In my map I have as background / basemap a map from open layers plugin, so from google. On top of that there is a shapefile I created myself from a gpx with points. If I leave out the open layer plugin map, then I am able to export it as an image. – Teun88 Sep 22 '14 at 15:20
  • And I noticed that - when I add a different layer from the google open layer plugin then some of them are able to be exported as an image, but then the points are not alligned with the map underneath it. – Teun88 Sep 22 '14 at 15:35
1

You could try under Item properties of your map a different setting: Cache, Render, or Rectangle.

  • 1
    Tried, but in both cases it does not work. Yeah, maybe a bug...quit annoying though. – Teun88 Sep 22 '14 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.