2

I'm trying to generate a heatmap of vehicle-pedestrian collisions in Los Angeles using data taken from UC Berekely TIMS. TIMS provides an exhaustive database of traffic accidents involving injury in the state of California.

I have a subset of the data mapped out in QGIS, and I'm attempting to create a heatmap using the heatmap plugin. However, instead of getting a heatmap, I get a solid black heatmap file. Moreover, when I try to open the properties screen, QGIS simply alerts me, "Bad Allocation," and won't refuses to open the property screen. I am using the default settings, with a radius of 200m (though I also tried 50m).

Screenshot of settings

I tried to do this in QGIS 2.0, but I still get the black box. Am I missing some critical information on how to use the heatmap plugin?

3
  • What's your data CRS and your project CRS? If your data is in WGS84, try reprojecting it. You could also include a screenshot of the QGIS window and the plugin settings you used.
    – underdark
    Sep 22 '14 at 20:14
  • Both are WGS84 right now. What projection would you recommend? I'll get a screenshot in.
    – jkho_
    Sep 22 '14 at 21:01
  • I think this is a bug in the Windows build of QGIS. I'll do some more testing and get back to you.
    – ndawson
    Sep 23 '14 at 1:47
2

There was a bunch of bugs in the heatmap code which I've now fixed. You can either download an updated development snapshot to get these fixes, or for QGIS < 2.6 there's some workarounds:

  • make sure your layer isn't a "multipoint" layer

  • there's a bug which causes the layer choice from the dialog not to apply the first time in a session. Rerunning the heatmap a second time should work around this.

2
  • That makes sense then -- I'm importing the data from Spatalite due to the sheer size of the database. I'll download a development snapshot and report back with the results.
    – jkho_
    Sep 28 '14 at 21:54
  • Sure enough -- Singlepart geometry (Used VEctor -> Geomtery Tools -> Multipart to Singleparts) is a usable workaround in QGIS 2.4!
    – jkho_
    Sep 28 '14 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.