While I am learning to create a python plugin in QGIS 2.4.0, I have followed the procedure explained in "https://qgis.readthedocs.org/en/latest/docs/pyqgis_developer_cookbook/13_plugins.html#developing-plugins".

When I initiated QGIS, and opened the Plugin manager, it says under the "Invalid" tab,

This plugin is incompatible with this version of QGIS Plugin designed for QGIS 1.8 - 1.9 This plugin is experimental HelloWorld This is a plugin for greeting the (going multiline) world

Can anybody help in describing the correct procedure?

  • 4
    Did you change the qgisMaximumVersion to 2.4 instead of 1.9 as mentioned in the document? – Joseph Sep 25 '14 at 14:27
  • 2
    I suggest you use the Plugin Builder plugin to generate a working template for you to start from... – gsherman Sep 25 '14 at 16:56
  • Yes, I have changed "qgisMaximumVersion to 2.4" in metadat.txt but the problem remained.... – Sesu Sep 26 '14 at 6:47
  • Then it may be best for you to follow @gsherman's suggestion which should avoid the compatibility issue. – Joseph Sep 30 '14 at 11:17

You could try to follow these steps: http://anitagraser.com/2014/04/26/getting-started-writing-qgis-2-x-plugins/ With this combination of Winpython, Plugin-Builder and Plugin-Reloader you should be able to get a good basic Plugin to fill with the functionality you are trying to implement.


On 2.4 to recent versions, you can use the Plugin builder to help making a basic structure : https://plugins.qgis.org/plugins/pluginbuilder/

It seems the minimum QGIS version is 2.0 so it should work even on an old version.

However, i guess after QGIS gets to 3, there might be some compatibility problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.