I have a problem with GRASS GIS 6.4.3.

I installed QGIS 2.4 with GRASS GIS 6.4.3 GUI on Windows 7 64 bit - admin user. When I click on GRASS GIS icon the program not starting (without error messages). I see the first map (loading gui) but the software not starting.

I tried uninstall and reinstall software but the problem remain.

Can someone help me?

Sorry for my english.

Best regard

PS If I call GRASS from cmd (windows) I read error like in image file

error message

3 Answers 3


The LOCATION_NAME variable is not set. To start a project with GRASS, you need to set a "fully qualified initial mapset directory" which is defined by a "GISDBASE/LOCATION_NAME/MAPSET" path.

Have you tried to launch GRASS from the start menu instead of the cmd window? After this first launch, you will be asked to set the variables.

  • Bonsoir Pierre. Yes, I tried to launch GRASS from the start menu. After the launch from start (or icon Grass 6.4.3 GUI) menu I see the old map image for only few seconds but grass not starting (like in this video ge.tt/5YD5Ftz1/v/0?c). Can I modify manually the location_name from command line?
    – Luca
    Sep 29, 2014 at 17:53
  • You are starting grass64 from the QGIS folder. Is GRASS installed elsewhere? Maybe can you try to create a new LOCATION from QGIS as described in this short tutorial : manual.linfiniti.com/en/grass/grass_setup.html
    – pzijd
    Sep 29, 2014 at 19:56
  • Hello. I solved the problem by installing grass 7 but I will try to follow your advice for grass 6. Thank you.
    – Luca
    Sep 30, 2014 at 13:08

Since GRASS GIS 6.4.3 should ideally start, maybe there is junk in the session configuration file (%APPDATA%\GRASS6\grassrc6 for GRASS 6 or %APPDATA%\GRASS7\rc for GRASS 7) where %APPDATA% is usually C:\Users\\AppData. To test, rename it and a new one will be created next time you run GRASS GIS. Note that %APPDATA% is a hidden folder.

(cited from http://grasswiki.osgeo.org/wiki/WinGRASS_errors#The_startup_fails_with_a_GISDBASE_not_defined_error)

  • Hello. I renamed the file, but the problem remained. I solved the problem by installing grass 7 3-1 beta (only for grass 7, grass 6 not starting). Thank at all.
    – Luca
    Sep 30, 2014 at 13:03

I have been working with GRASS GIS 7.2.0. The program finished wrongly and now, when I do click on GRASS GIS icon the program doesn't start. The error message is "variable location_name is not defined" I have attented uninstall this version and reinstall 7.2.2 (new release) but the problem remains. Thanks for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.