1

I have two layers. One is a layer of USA ecoregions (there are 9 ecoregions). It is not raster (so it's vector?). The other layer is the National Land Use Data set (so I know where there's agriculture, forests, ect.) and it is raster data. Sooooo.... I don't know how to analyze the land use types in each ecoregion because the two files are in different formats.

I attempted: ArcToolbox -> Conversions -> raster to polygon, but when my polygon appeared it had no land use types in it.

I attempted: ArcToolbox -> Conversions -> polygon -> raster but I waited and it did not finish calculating in a timely manner.

I am trying to identify the amount of Evergreen forest (part of the land use raster data) per ecoregion.

  • 1
    Do you have the Spatial Analyst extension? – evv_gis Sep 29 '14 at 15:42
  • Yes, I do have the extension. – WolverineTime Sep 29 '14 at 20:44
  • Before I leave a lengthy answer with other possibilities, I'm curious to why your Raster to Polygon conversion did not work. Make sure you set the Raster Field to the Value field. This will create each polygon feature based on the land use type. From there a spatial join is pretty easy to do. – evv_gis Sep 29 '14 at 21:21
  • Hi, my process was: Arc toolbox -> Conversion Tools -> From Raster -> Raster to Polygon. For 'input raster' I put the NLCD file (raster) and I have tried keeping 'field' at Value. I received an error message (I can not attach a screenshot here, can I?). The error says: "Output polygon features: <empty>. Then it says Error: Error executing fuction. And it says Cannot open database. Unable to allocate memory. Error in executing grid expression. Failed to execute (rastertopolygon). Any advice? – WolverineTime Oct 1 '14 at 16:11
  • The NLCD dataset is a huge 17 gigabyte raster, I'd guess that your computer just can't handle the whole thing at once. You could try splitting the raster up into separate rasters, one per ecoregion, and run each one separately. – Dan C Oct 1 '14 at 17:58
1

You can do this using the "Tabulate Area" Tool (Spatial Analyst Toolbox). You won't need to convert the data because you can use the polygon layer as the "zone" layer (sometimes called the "class" layer) and the raster land cover as the "value" layer. The class/value values will likely be numeric (which may explain why you didn't see any land use types after converting raster to polygon; i.e. is there a gridcode field? It may be your land cover values). Look at the table for the land cover layer to see how the land cover types are coded.

Tabulate Area will give you a tabular output summarizing the area of each of your coded land cover types. This should do what you want. You can usually join this table back to the zone layer if desired.

EDIT: Sometimes your environment settings are particular in ArcMap. You may want to set your processing extent and set the snap raster to your LandCover layer (see screenshot). There is temporary output that is raster based so that may help. ArcMap is finicky. Sometimes closing arcmap and starting with a fresh map even works for some unknown reason. Be sure both layers are in some type of Projected Coordinate System. Tabulating AREA based on anything else isn't going to work very well. I'd recommend using Albers Equal Area because that Coordinate System works well with Area Calculations.

Environments

  • Hi @jbchurchill, I have tried to use Tabulate Area. But this did not work. I tried the following: Input raster or feature zone data: NLCD raster file. Zone field: Value. Input raster or feature class data: HUC8 (not raster). Errors: Error executing function. Error General Function failure. Error too many fields defined. Error failed to execute (tabulateArea). – WolverineTime Oct 1 '14 at 17:28
  • Are your layers in the same coordinate system? Sometimes that makes a difference. Did you get any kind of output at all? – jbchurchill Oct 1 '14 at 17:29
  • When i look on the map both layers show up on top of each other. And they are both listed as Datum: D_North_American_1983. – WolverineTime Oct 1 '14 at 17:32
  • Try setting some Environment settings (Processing Extent in particular). I'll add a screenshot to my answer to demonstrate. You can set your Environment settings by right-clicking the background area (white space) in the toolbox panel, and selecting "Environments". Trust me Tabulate Areas is the way to go. I've done this 100s of times. – jbchurchill Oct 1 '14 at 17:37
  • Oh Snap. You said your data is D_North_American_1983. You have to use a PROJECTED COORDINATE SYSTEM. If your data is in Geographic Coordinates, this isn't going to work. – jbchurchill Oct 1 '14 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.