I have been installing GeoServer locally many times for the past year on Windows XP machines. Now I am trying to install it on our new Windows 7 Machines. However the installation (of the stable version 2.5.2) seems to proceed differently, No longer do you get a menu on the start menu to launch it, in fact you have to hunt around to find GeoServer.

When I tried to launch it (from the startup batch file I found in the Bin directory) nothing happened, various re-installations of all the different versions I could download and I found that putting geoserver in the programs directory (as opposed to the default program files (x86) directory) resulted in a installation that worked, once... but now the batch file no longer works. I have varied the port between the default 8080 and various others to no avail, so it does not seem to be a port conflict. I am really confused as to why the menu is not there, the program seems suddenly very different.

Am I doing something wrong?

  • Did you install it to run as a service? Commented Sep 30, 2014 at 12:01
  • Yes we did, we had previously tried both but the one time it worked we had selected to run it as a service
    – user24956
    Commented Sep 30, 2014 at 12:15
  • 2
    The startup.bat in GeoServer 2.6-RC1 has an improved logic for finding the installed java from Windows 7 and rising the rights for the installation directory and data_dir. You can either install 2.6 or just copy the startup.bat into your 2.5.2 installation and try if it works better. It may be that the buttons appear into Start menu only if you have logged in as admin when running the installer.
    – user30184
    Commented Sep 30, 2014 at 12:46
  • That's done it! I tried installing while logged on as Admin, and lo and behold the Geoserver link appears in the menu! It now works though the link does not appear in the menu for non admin users. Thanks for the help!
    – user24956
    Commented Sep 30, 2014 at 13:06

1 Answer 1


The installer in GeoServer versions <2.6 has an issue with Windows 7 which makes installation into "Program files" or "Program files(x86)" to fail because Win 7 requires elevated privileges for those directories and the old installer does not take care of that.

The installer in GeoServer 2.6 is fixed to raise the privileges and installation into Program Files works. There is still an issue with the Start menu shortcuts. If installer is started from user account no shortcuts at all are created. Running installer when logged in as admin creates the shortcuts but only for admin.

Installation of GeoServer version 2.5.x or below on Windows 7 with the installer works only if any other directory than "Program files" is used. Problem with shortcuts remains.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.