1

I am trying to create an enterprise geodatabase in oracle 11g, using the create enterprise geodatabase tool in arcmap 10.2. I have properly installed the oracle client needed and I am able to create a database connection (both as sys and system users).

However, when I am trying to execute the tool create enterprise geodatabase, it fails. I asks for administrator username and password as shown in the image.

enter image description here enter image description here

Any ideas about how this could be resolved or debugged ?

  • You might try going to menu Geoprocessing -> Results. Might give you a bit more details. Also, don't use Oracle :p. Seems like ArcGIS.com themselves have moved to PostgreSQL! – janechii Oct 1 '14 at 17:26
  • If I could, maybe I would :) However the dbms of our system, which already contains non spatial information is in Oracle. As a result I would like to use some of the existing tables containing spatial information as well as non spatial info. – Smalis Oct 1 '14 at 21:15
1

You will need the sys password of that Oracle instance in order to run the create enterprise geodatabase. If you have another user with dba privileges you can run this to change the password:

alter user sys identified by NEWPASSWORD;

If you have a database administrator in your organization, they should have the sys password.

Optionally, if you have an Oracle database created you can run the enable enterprise geodatabase tool to create the SDE system tables.

http://resources.arcgis.com/en/help/main/10.1/index.html#//001700000162000000

  • 1
    Indeed, Enable Enterprise Geodatabase can be used as a replacement for Create Enterprise Geodatabase, IF you issue the necessary PUBLIC grants and create the SDE tablespace and SDE user beforehand. – Vince Oct 1 '14 at 22:49
  • The fact is that I am using an oracleXE so as to have administrator rights. However using the sys password I have set on my own has no results. – Smalis Oct 2 '14 at 7:52
0

The problem was that I was not completing the geodatabase administrator field since it says that it is optional. When I provided one, it worked properly.

0

I do have sys and sys' password but still can't create enterprise geodatabase. It complains, "bad login user failed to execute(CreateEnterpriseGeodatabase)" How can I resolve it?

  • The original question is several years old. You would be best off crafting your particular issue as a new question so that others can help out your particular needs. – jbukoski Jun 5 '17 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.