2

I'm working with Quantum GIS 2.4 and I would like to overlap a DTM (.asc) and a shapefile. The shapefile is a copy from the another, to make some trials, who had WGS84 as original CRS; I saved it by adopting EPSG:3857 as the default CRS. I would like to visualize everything in PseudoMercator: I create a new project, set the CRS as 3857, enable the 'on the fly' transformation but my shapefile is quite far from the DTM.

I think this could depend on the qpj file, who still has the WGS84 information: how can I solve this?

  • 1
    What does QGIS say about your DTM's CRS? (Properties, general tab) Does your DTM has a prj file with it? If you exported your shape with the Pseudo CRS, your qpj has to start with the following: PROJCS["WGS 84 / Pseudo-Mercator"[...]. – Gabor Farkas Oct 2 '14 at 9:46
  • Can you add the extent of your raster and shapefiles, as reported by Rightclick on the layer, Properties, Metadata tab? – AndreJ Oct 2 '14 at 10:36
  • Yes, I can check everything and I created different copies of the same shape, each one with a different CRS. But when I open them, no matter which reference system I assign to them, they are completely spaced from my polylines. – JacopoCerri Oct 2 '14 at 10:39
  • 1
    Assigning a CRS does not reproject your raster or shapefile, but corrupts your data. Therefore I asked for the extents. That's the only thing that is not affected by assigning wrong CRS. – AndreJ Oct 2 '14 at 11:55
1

Open the original file in a blank project (set the correct EPSG of the project first) Disable "on the fly" transformation. Save the shp adopting the new epsg.

Now, if your raster is in 3857, your shape file must be ok without "on the fly" transformation.

  • This approach doesn't work. Everything is quite odd, at this point I'm not even sure about the default CRS of my raster. When I set the CRS, havig a look at the metadata, both the projection systems have the same formula, but they are displaced at two different locations! I generate the shp with EPSG:3857, this is the only thing I'm sure of (I was working with the WMS Bing service) – JacopoCerri Oct 2 '14 at 10:12
  • This is very weird: I even tried to just open a new project and then to add layers, checking their CRS without setting anything. The problem is the same: same CRS, different positions on the map. This pattern keeps appearing for every CRS I use: WGS84, World Mercator, PseudoMercator. – JacopoCerri Oct 2 '14 at 10:19
  • You don't have any other layer that you are sure that it is in 3857? I think that the problem is in the raster not in the shp. Rasters can't be reprojected on the fly. You must reproject them with gdal (Raster->conversion->translate), but if you set the wrong starting EPSG the result will be obviously wrong – Sergio Oct 2 '14 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.