2

I have ArcGIS 10.2.2 Desktop, License type: Advanced, installed on a windows 7 64 bit machine.

It normally takes about 12 seconds to initialize the license, whether in ArcMap or a stand alone Python script.

Suddenly today it is taking about 50 seconds. The only thing I can think of is that I ran the Advanced System Care Iobit registry cleaner but I am fairly sure I have done this before since I installed 10.2.2 without problems.

I have had similar start up times before after installing an upgraded version of ArcGIS and the only way I found to cure it was to uninstall it, remove all traces from the registry and re-install but I would dearly love to be able to fix it without going through all that again.

Can anyone suggest a way to find why it is taking so long?

closed as off-topic by PolyGeo Mar 24 '17 at 9:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Have you installed additional add-ons? After I started using ArcHydro startup went from ~10 seconds to ~45-60. – Erica Oct 4 '14 at 14:55
  • No - nothing like that – user2795136 Oct 7 '14 at 6:17
  • Should be re-opened. Same behaviour observed on 10.4.1, with Brad's answer being the cure. – matt wilkie Oct 25 '17 at 17:30
  • Also see Geonet ArcMap 10 hangs at Initializing Application – matt wilkie Oct 25 '17 at 17:55
2

Look at the taskbar tray icons on Windows and deactivate the arcgis online Connection
enter image description here
enter image description here
tick "Never check" and test for better speed on startup.
If that helps something changed with your internet connection in the past few days.

  • I had same symptoms as OP with ArcMap v10.4.1. Turning systray ArcGIS Connection Properties to either of "Never Check" and "Periodic check: 60s" solved the problem. Using Connection Test showed "pass" for Proxy and Download, "undetermined" for Latency and "failed" for Route. If I sign in (ArcMap >> File >> Sign In), subsequent arcmap starts are short. – matt wilkie Oct 25 '17 at 17:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.