2

Using ArcMap 10.1, I’m editing values in a feature class which was sent to me from within my organization. I realized I had a problem when trying to change the symbology of this feature class- the values I updated appear in the attribute table but some don’t appear in the Properties dialog box when I try to change the Symbology to categories/unique values (trying to visually highlight the new values I've added).

The structure of the attribute table cannot be changed as it was created to link with other systems. The problem is only occurring with one field; other fields which I updated do have their unique values appear in the Properties dialog box. I checked to see if this was created to be a Read-only field and it was not... Is there some protection on the feature class I don't know about? Did the edits I made somehow not get stored? Edits were made using field calculator + some manual edits in a Edit session which have all been saved.

closed as off-topic by PolyGeo Oct 3 '16 at 6:17

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Do all of the values show up when you try to build a definition query or a select by attributes operation? Just something to try out... – mr.adam Oct 7 '14 at 18:25
  • @mr.adam yes in fact they do... any idea why they just seem to not be there when trying to edit symbology? – zabro Oct 7 '14 at 18:32
  • Does the field that's giving you problems have a domain or subtype attached to it? – John Oct 7 '14 at 18:32
  • 1
    Is the FC using representation rules for symbology? – landocalrissian Oct 7 '14 at 18:43
  • I have had similar problems in the past where if I stopped the edit session (and/or restarted it), things began working normally again. While it would answer the why, it might provide a workaround. How many categories/unique values are we talking about? – Chris W Oct 7 '14 at 19:42
0

In the symbology tab, go to Add Values, then click the Complete List button. All the values that are not currently symbolized should appear. Highlight the new values and hit OK to add them.

  • 1
    Thanks for your response. I have tried that but the new values do not show up. I also tried adding a New Value to the list and entering one of my new values (the field is numeric) but the count shows up as "?" and nothing is symbolized on the map. – zabro Oct 7 '14 at 17:35
  • What happens if you open up a new MXD, add the fc and symbolize values? Do they appear then? – detroit_hc Oct 7 '14 at 17:45
  • I tried that too in multiple MXDs, still the same problem. I noticed the problem a few days ago and it has recurred after shutting down and re-starting Arc and computer. – zabro Oct 7 '14 at 18:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.