2

I've created a tool that runs from a model built in ModelBuilder in ArcGIS 10.1. Right now, I can run the tool with no problem from my computer, but no one else can run it successfully.

I've changed the tool's Environment Settings to run on a Scratch database that others have access to (Fig.1), and the remaining output data is defined by the user within the tool itself.

Unfortunately, the tool will still not run for anyone else because it's still trying to access my own default geodatabase.

How might I override this - telling the tool to only try accessing the Scratch gdb defined in the tool's Environment Settings for the intermediate data, and NOT my default geodatabase that Arc normally tries to use?

Fig. 1: Fig. 1: Environment Settings

1

Found what was causing the model to use my default gdb. Just needed to check the paths of the intermediate data within the model. Some of the intermediate data had leftover paths to the default gdb. I just repathed those to the Scratch gdb that I specified in the Environment Settings and everything runs now on other's computers.

  • 1
    Good find. Another option would be to point all of that intermediate data to the in_memory workspace. It would eliminate specific references to a location on disk, and might even speed up your model processing. Even though Ways to Speed Up Python Scripts Running As ArcGIS Tools references using Python, the use of the in_memory workspace applies the same for ModelBuilder. – RyanDalton Oct 7 '14 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.