3
  • I have created and Oracle 11g geospatial geodatabase and have create an arcsde connection.
  • I have been connected using arcmap, as a simple user (not sde or schema-user), who has all the proper rights to edit tables etc..
  • I use arcgis for desktop 10.2.
  • In my geodatabase I have created all my business tables needed for my applications. In this geodatabase there is on table tha contains X Y points.
  • I suppose that I need to add an st_geomery column so as to enable arcgis realise that it contains geometries (points), have indexing etc.

  1. One option is to alter the table via an oracle query and add an st_geometry column. In this case I cannot see the table in the listed tables in arcmap. I dont know why.
  2. I suppose that a second option could be to edit this table through arcmap and add a st_geometry column of points. But I cannot find any option in arcmap to do this.

When I double click on my table i can see these options (missing st_geometry option)

enter image description here

Any help on these two options?

  • 1
    Tables are altered with DDL, not queries (DML). Was the table registered with the geodatabase prior to altering the table? – Vince Oct 8 '14 at 11:53
  • Yes Vince. It has been registered. – Smalis Oct 8 '14 at 12:28
  • Also I want to mention that as I have noticed . When I register a table to a geodatabase, the changes (ex add a new column) I make from inside the Oracle Sql Developer client are not visible in arcmap. even after refreshing my sde connection. I tried the same with a not registered table an the changes are visible. – Smalis Oct 8 '14 at 12:31
  • 1
    You should not issue DDL against tables after they have been registered with the geodatabase, since this corrupts the registration. – Vince Oct 8 '14 at 14:08
  • 1
    It looks like you just want the second option offered in this link resources.arcgis.com/EN/HELP/MAIN/10.2/index.html#//… – Vince Oct 8 '14 at 14:15
0

The problem was that the st_geometry had not been correctly installed at the time I ran the Create Enterprise Geodatabase Tool.

I had to fix the exproc file so as during the creation of the geodatabase, the st_geometry to be properly installed.

The absence of St_geometry made my Arcgis recognise the tables containing st_geometry as invalid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.