We have some Panasonic ToughPads (FZ-G1) with a GPS a module built in.

I know where it is and can locate in it in COM 3 and it connects, registers a signal, shows satellite locations, but refuses to give me a any details. It also doesn't place a cursor where I am located on the map.

How does QGIS decide what Baud rate to use?

Is there a way I can manually set it?

or can anyone recommend a better plug-in?

closed as too broad by PolyGeo Dec 9 '17 at 20:21

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you enable logging and have a look at the output NMEA strings to see what the issue might be. – Nathan W Oct 8 '14 at 13:16
  • Have you tried using the GPS information panel with gpsd? – AndreJ Oct 8 '14 at 13:16
  • Logging seems to be fine, can't see any problems within that. I can use other programs as well and I receive a long and lat. Just not on GQIS. – Dave Oct 8 '14 at 13:25
  • Which QGis plugin (if any) do you use? – til_b Oct 8 '14 at 13:47
  • I'm using GPS Tools – Dave Oct 8 '14 at 13:54

You can try GpsGate to relay GPS input over a virtual COM port with selectable baud rate. The GpsGate Express Client is free of charge.

It works for me with a Garmin device connected via USB inside QGIS.

  • I cant get it to work. It finds the GPS but then QGIS won't connect to it. Is it best to emulate a new serial port? Can you suggest the best output to use? – Dave Oct 9 '14 at 9:20
  • That's rather strange, because QGIS gets the satellite information, so it should get the position as well. A virtual COM would be the last chance I see. You could try visualgps.net/visualgps to see if that can read the location info. – AndreJ Oct 9 '14 at 10:05
  • Thanks GPS gate worked a treat. Used it for my panasonic FZ-G1 Tablet for global mapper. In setting for global mapper i used Garmin format, COM 1 with 9600 Baud rate. In GpsGate i made the active output Virtual COM1/Garmin Emulator, while the input was COM3, 9600 baud rate. – user49686 Mar 28 '15 at 5:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.