I am installing Whitebox GIS software on linux.

I have already:

  1. set up a clean xfce4 machine
  2. installed java 8 successfully
  3. unzipped the latest version of whitebox (Iguazu 3.2.1) to the desktop

Whenever I click on the JAR file or try to run through terminal nothing happens.

Am I missing some key dependencies?


2 Answers 2


It's been quite some time since I've used Linux, but I seem to recall two general ways of launching Java programs.

  1. It can be launched from the command line as you would on any other system:

java -jar /full-path-to/WhiteboxGIS.jar

  1. Navigate to the Whitebox folder. Right click the WhiteboxGIS.jar and select 'Properties'. Mark the file as executable (i.e. set the executable bit). You may have to associate the jar extension with Java on your system, if it isn't already. After this point, you should be able to launch it by double-clicking WhiteboxGIS.jar as you would normally.

I just had the same problem. Solved it by installing openjdk-jre-8, then running

update-alternatives --config java

which gave me this (yours may be different):

There are 3 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
* 0            /usr/lib/jvm/java-13-openjdk-amd64/bin/java      1211      auto mode
  1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      manual mode
  2            /usr/lib/jvm/java-13-openjdk-amd64/bin/java      1211      manual mode
  3            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

so now I could cd into my WhiteboxGAT dir and run

/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java -jar WhiteboxGIS.jar

and it worked fine.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.