1

Lately I've been using r.grow through the QGIS Processing Toolbox on several rasters which represent the whole world with 500m grid spacing. It takes many minutes to save the output. The reason seems to be that by default, GRASS Processing calls r.out.gdal after the r.grow command to save the output, and it does so with the argument -c createopt="TFW=YES,COMPRESS=LZW". The LZW compression for a raster of this many cells is quite slow, and I don't need it -- I'd rather just have PACKBITS. So, how do I change what it give to createopt? I couldn't find anywhere in the QGIS GUI to change this setting.

1

These options are hard-coded in GrassAlgorithm.py so I just changed them. I'll probably write a fix for this (put it into the Processing settings) if I get the time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.