1

I try to get the QGIS Server running and just try to establish a first WMS. I tried to follow http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial#Windows and http://anitagraser.com/2012/04/06/qgis-server-on-windows7-step-by-step/

I already have problems with the installation. All manuals seem to be outdated. I downloaded the osgeo4w file and it starts with installing QGIS 2.5 I would have thought that it installs QGIS 2.4. But what the heck. Then all manuals refer to the folder c:/osgeo4w/apache/conf/httpd.conf But the installation via osgeo4w does not include an installation of apache anymore.

So no I do not know how to go on. Do I have to install apache in my own or is there another solution without the apache?

I just tried to install apache to c:/osgeo4w/apache/ with the port 81. I get the message "It works!" in my Browser. I wanted to copy the files

libeay32.dll and ssleay32.dll from C:\OSGeo4W\apache\bin to C:\OSGeo4W\apps\qgis\bin.

As mentioned in the first "How to" but these files does not exist in this directory and they do not exist in any directory of apache. These two files are in: C:\OSGeo4W64\bin

I tries to copy the in both first mentioned directories and tried to start the adjusted capabilities request mentioned in the "How to", but the the file is not found on the server

localhost:81/qgis/bin/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

What can I do to make an WMS running via QGIS?

  • Mixing OSGEO4W and OSGEO4W64 might not work. Since apache is not in the 64bit-build, you have to run 32-bit QGIS from OSGEO4W. – AndreJ Oct 20 '14 at 7:52
  • 1
    I got it running. working with OSGEO4W was the solution – pinkyinbrain Oct 26 '14 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.