1

When I tried to create a buffer layer around a polyline layer. But I got the error as follows:

The input was outside a +-360 longitude range or outside +-90 latitude.

enter image description here

The input is : dev_db.DBO.Segment

The output is : D:\local\SegBuffer.shp

The buffer size : 10 meters

The error occurs regardless of the buffer size. Any hint on it?

I am using arcmap 10.2.2.

  • 1
    Could you give a little bit more information about the dataset you want to buffer? Is it a Shapefile or from a Geodatabase? My first guess would be that there is an issue with the coordinate system. Which coordinate system are you using? – Martin Oct 20 '14 at 6:37
  • 1
    Would you be able to copy/paste (or re-type) the precise error/warning message into your question as text, please? The picture is useful too but will not show up in a search. Would you also be able to include the precise parameter values that you supplied to the buffer tool, please? – PolyGeo Oct 20 '14 at 6:48
  • Hi Martin, I am buffering a Geodatabase layer. The coordinate system is GCS_SVY21. – ppLily Oct 20 '14 at 7:03
  • Unfortunately I couldn´t reproduce the error. What kind of database are you using (ESRI or other)? Might not be a bad idea to see how the coordinates are saved in the database to check if the error message is correct. – Martin Oct 20 '14 at 7:54
  • 1
    I can't reproduce it either, and even googling yields no result. Deducing from the error message I'd say it could be a problem with a geometry which sits outside the defined bounds of your coordinate system, but all I get is a warning: conflict between map and output. I would take this to ESRI if I were you, especially as there is no online source at all (not even one from ESRI!) which references your error. – Menno Oct 20 '14 at 8:55
1

I get the same error and I can't figure why. I noticed that this happens only when attempting to make a geodesic buffer on polyline or polygon (but not on point) features with a non-earth geographic coordinate system. I still can't figure why this happens, but I figured out two possible workarounds:

  • WORKAROUND #1 (easiest one):

    Use the "Buffer Wizard" tool (Customize > Toolbars > Customize... > Commands > search for "Buffer Wizard") instead of the ArcToolbox Buffer tool. This tool does not return the error.

  • WORKAROUND #2 (useful just for polylines):

    1) Densify your polyline vertices (i.e. System Toolboxes > Editing Tools > Densify);

    2) Convert your polyline features to point features;

    3) Use the Buffer tool (i.e. System Toolboxes > Analysis Tools > Proximity > Buffer) setting Method = GEODESIC AND Dissolve type = ALL.

However, I hope that an actual solution to this problem comes out sooner or later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.