I am using GeoServer 2.6 Final War File in Tomcat. I am setting up GeoWebCache and I am attempting to seed a table from Oracle that has about 600,000 records. (I used the Oracle NG provider to create the Data Source).
I select the following options from GeoServer under

"Tile Layers" >> "Seed/Truncate" for that layer:
  • Number of tasks to use: 01
  • Type of operation: Seed - generate missing tiles
  • Grid Set: EPSG:2236
  • Format: image/png
  • Zoom start: 00
  • Zoom stop: 18

I then click on Submit and see the following:

Id|Layer   |Status |Type|Estimated # of tiles|Tiles completed|Time elapsed |Time remaining|Tasks     
49|sf:MV0_1|RUNNING|SEED|2,857,446           |-1             |Estimating...|Estimating... |(Task 1 of 1)

Then I click on "Refresh list" and in about 10 seconds it is no longer there...I was trying to look in the logs folder and found no logging in:

C:\Program Files\Apache Software Foundation\Tomcat 8.0\logs

which is where GeoServer is installed.

Why is the seeding not working?

Here is the gridset 2236 defined in geowebcache.xml:


Answering a question from comments:

"Does the preview of the integrated GWC show maps for you?"

I click on "Tile Layers", Then select the "EPSG: 2236 / png" to preview the cached tile. I get some tiles that display. (Only the ones generated before the process dies as mentioned above)

Answering another question from comments:

"You need to make sure that your Gridset in GeoWebCache matches what you have setup on the Layer in GeoServer."

Yes, the layer matches the gridset in GeoWebCache:

Data>>Layers>>Edit Layer>>Tile Caching>>Available Gridsets

One item shows:

Available gridsets 
Gridset: EPSG:2236
Published zoom levels: min/max
Cached zoom levels: min/max
Grid subset bounds: Dynamic

Also under "Tile Caching">>"Caching Defaults">>Default Cached Gridsets, I have only:

Gridset: EPSG:2236 
CRS : EPSG:2236
Tile Dimensions: 256 x 256 
Zoom levels: 19
Disk Usage: 465.63 MB

Also under "Tile Caching">>"Disk Quota", disk quota is enabled and set to 1.953 GB.

Answering a question from comments:

"Do you have write permission for the logging folder?"

Yes, other log data is being updated in that folder such as :

C:\Program Files\Apache Software Foundation\Tomcat 8.0\logs


Answering a question from comments:

"Browse the folder and see if the images are stored? I remember that Geoserver couldn't read my folder size once, so I didn't think the images were cached but they were there when I browsed to the directory. Perhaps this is similar?"

Yes, there are some images maybe a handful which are created just before the seed tasks die. They are in the

C:\Program Files\Apache Software Foundation\Tomcat8.0\webapps\geoserver\data\gwc\

folder under subfolders.

I also want to mention that there is another oracle spatial table (setup under another layer) with same layout but with only 1300 records and that one does complete normally.

I found the error in the geoserver.log that is causing the gwc to stop:

org.geoserver.platform.ServiceException: This requested used more time than allowed and has been forcefully stopped. Max rendering time is 60.0s

  • Seeding process does not tell too much about how it is going. What you see can happen if there is nothing to seed (cache is seeded already) or if GWC believes so. I suppose that cache is not full in your case. Reseed feels somehow more reliable for me. Try with reseed and use for example 4 threads. It is also good to increase the reliability by splitting seeding to smaller bounding boxes so that the task finishes before all the threads die. – user30184 Oct 20 '14 at 19:28
  • Unfortunately, I already tried those options including choosing either "seed or reseed" and choosing up to 10 tasks to use. I just tried it again right now with 4 tasks and all 4 disappeared in less than 30 seconds. – user3657279 Oct 20 '14 at 19:47
  • 1
    Does the preview of the integrated GWC show maps for you? I mean the ones that can be opened from localhost:8080/geoserver/gwc/demo? Check especially your custom EPSG:2236 gridset. – user30184 Oct 20 '14 at 19:53
  • 1
    Most likely it is a GridSet Issue, you need to make sure that your Gridset in GeoWebCache matches what you have setup on the Layer in GeoServer. You might like to include the relevant layer excerpt from the GeoWebCache xml file and a screenshot of your Geoserver Layer Page Setup .. – Mark Cupitt Oct 21 '14 at 1:02
  • do you have write permission for the logging folder? – Ian Turton Oct 21 '14 at 7:57

I found the answer to the issue, although there is no available solution. It is a known bug where GeoWebCache stops forcefully. It looks like there is no current solution for bug # GEOS-6278:


If a solution is available in the future for GeoWebCache, I will update this post.

|improve this answer|||||

I know this is an old thread, but probably it can help others who reach here. One more reason for GWC dying prematurely (or not showing any status at all upon clicking refresh) is when you have data level security or user roles or service level security. Disabling them worked like a charm for us and we enabled them again after suffiecient caching. We are running GeoServer Version 2.13.1 and GeoWebCache Version 1.13.1.

|improve this answer|||||

Have a look at this GeoServer Documentation JVM Considerations.

The options could be edited into "startup.bat" file located in (C:\GeoServer_Installation_Folder\bin).

|improve this answer|||||

Probably already found this....but incase someone else sees the post... Make sure you set the WMS global timeout to something larger than 60secs (default). GWC requests the tiles from the WMS service, which needs to have sufficient time to render your data to an image.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.