1

I want to use OSGeo Live VM 8.0 as a test GeoServer. Following its website, I started the server by

Select the Geospatial ‣ Web Services ‣ GeoServer ‣ Start GeoServer in the menu

But after rebooting the server, geoserver is down again. How do I start geoserver automatically as if I installed geoserver myself on a fresh Ubuntu?

Thanks.

2

I have figured it out by tracing the various shortcuts in Lubuntu. Basically, it involves creating a init script in /etc/init.d as listed in the bottom, which starts tomcat and call the content of the osgeo geoserver start script. Note: restarting tomcat is not good enough as I had thought.

After that do:

update-rc.d myscript defaults 99 01

Init script:

#!/bin/sh
### BEGIN INIT INFO
# Provides:          myscript
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start daemon at boot time
# Description:       Enable service provided by daemon.
### END INIT INFO

case "$1" in
  start)

    service tomcat6 restart
    /usr/local/lib/geoserver-2.5/bin/startup.sh

    ;;
esac

quit 0

-- UPDATE --

After some digging, I found that OSGeoLive (8.0) favor of GeoServer is powered by jetty, not tomcat, though both are installed. That explains why starting tomcat does not start geoserver.

  • Just to clarify; isn't GS a webapp of tomcat? if its properly installed it should be serving data after tomcat starts – nickves Oct 23 '14 at 21:34
  • That's what I thought. But on my OSGeoLive VM, GeoServer didn't start with tomcat6. Really don't know why. – tinlyx Oct 23 '14 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.