2

I've tried the other "how to clip" instructions here, but consistently get an empty shapefile from the clip.

QGIS Version: 2.4.0-Chugiak

OS: MacOS 10.10

Input File: San Diego (South Map) 1999 Topo (2' intervals) (1 GB Download Link)

I've assigned the same CRS from the San Diego Vector Layer to the polygon clipping mask.

Here is a screen capture of my process:

QGIS Vector Clipping Path Producing Empty File

Hopefully someone can point out where I'm going wrong with this process.

  • from your video (very helpful to see) you need to stop editing and save your polygon file. then clip should work. – Mapperz Oct 23 '14 at 18:55
  • Hey @Mapperz, thanks for the suggestion. I tried that and no luck. Still getting the empty file shape. – Tigre Oct 23 '14 at 20:59
  • Thanks, @Mapperz, that helped. If you want, post an answer with those steps and I'll vote it as the answer. Cheers! – Tigre Oct 23 '14 at 21:37
1

Please DO NOT use Set CRS for Layer if you want to reproject a vector layer to another CRS. This will corrupt your data, because it does not recalculate any coordinates.

Use Rightclick Save As ... under a different file name and different CRS.

You better set the layer back to the previous CRS, or delete it and reload a fresh copy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.