2

I don't have problem direct connecting arcgis to postgresql if my database name contains only letters, but when the name contains dashes or underscore e.g:"gisdb-dev", I receive an error when setting up direct connection using ArcCatalog.

Failed to connect to the specified server. Do you want to continue? Invalid SQL Syntax

I'm sure I didn't break any database name restriction on PostgreSQL or ESRI side. I've look around and can't find any solution for this problem.

Had anyone came across this problem and have a solution?

Environment:

  • Windows 7 Ultimate x64
  • ArcGIS 10.1 sp1
  • PostgreSQL 9.1.3 x64
  • PostGIS 2.0 x64

closed as off-topic by PolyGeo Nov 6 '17 at 20:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I connect to servers with hyphens in the name all the time. I think you need to provide more detail. – Vince Oct 24 '14 at 10:48
  • Are those hyphens in the server name or database name? My problem is the database name using hyphens. What detail needed to add to the description? – Zery Oct 24 '14 at 14:38
  • 1
    In the database name? No, that's not a valid SQL identifier. ArcGIS doesn't add oodles of quotes in every statement to trap for invalid characters. – Vince Oct 24 '14 at 15:46
  • So I can't have hypens in the database name if I want to connect from ArcGIS? – Zery Oct 25 '14 at 0:40
  • 1
    Underscores should be valid, but hyphens will be interpreted as subtraction (best possible case) or a syntax error. – Vince Oct 25 '14 at 3:15