1

After some package updates on my Debian machine all my database queries involving postgis functions or types are returning:

Error message from server: ERROR: could not load library "/usr/lib/postgresql/9.1/lib/postgis-1.5.so": /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.18' not found (required by /usr/lib/x86_64-linux-gnu/libstdc++.so.6)

Is there a way to resolve this issue? I have to move spatial data between machines, but pg_dump also fails. Is there another way to safely dump my postgis databases?

  • 1
    Have you tried sudo ldconfig? Also, what version did you upgrade from and to? – John Powell Oct 24 '14 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.