I have the same problem as in Writing shapefile with projection defined crashes fiona

It says that was an issue with GDAL.

I cleaned my site-packages of anything GDAL, fiona, six related. Then installed the following binaries from http://www.lfd.uci.edu/~gohlke/pythonlibs/

I using the Python27 ArcGIS10.2 interpreter

  • GDAL-1.11.1.win32-py2.7

  • Fiona-1.4.1.win32-py2.7

  • six-1.8.0.win32-py2.7

Tried running the code again:

with fiona.open(output_path, 'w', 'ESRI Shapefile', schema, crs=crs.from_epsg(4326)) as layer:
        for lat_long in lat_long_data:
            latitude = lat_long[0]
            longitude = lat_long[1]
            image_name = lat_long[2]
            point = self._create_shapely_point_shapefile(latitude, longitude)
            layer.write({'properties':  {'Name': image_name, 'Lat': latitude, 'Long': longitude},  'geometry': mapping(point)})
    return output_location

Python crashes and I get this error message:

Process finished with exit code -1073741795 (0xC000001D)

If I remove the crs param it works but I need it to work with the crs param.

  • do you have the proj4 libraries? – Ragi Yaser Burhum Oct 24 '14 at 22:49
  • It's likely that ArcPy has its own GDAL DLL that conflicts with Gohlke's. I'm almost certain that if you installed Python from python.org and reinstalled those packages, it would work. – sgillies Oct 24 '14 at 22:58

I tried solving this by re installing fiona. I was having the same problem. I installed fiona 1.4.8 and it solved the problem.

  • Were you using the IDE that comes with Arcmap? – Tristan Forward Nov 11 '14 at 15:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.