0

I'm a new user of GRASS 6.4.3 and I wanted to import ESRI ASCII grid.

Raster file was unzipped, and in r.in.arc window I specified name for output, storage type etc.

After it has run, raster didn't appear on Display, and in Command Console there was next message:

Command 'd.rast map=39_03@Slovenija_WGS' failed

Can anyone help me? Thanks in advance

  • Did it fail to import or to display? That's not the same thing... And which operating system do you use? – markusN Oct 27 '14 at 17:26
  • Operating system is Windows 7. It's hard to say did it fail to import because in r.in.arc window it seems that it worked, also in layer manager there is layer, but it's invalid because I can't see properties or do anything with it. And it is not displayed in map display. Furthermore, there is mentioned message about error in command console. – geof Oct 28 '14 at 15:06
  • Sidenote: We are going to remove r.in.arc in GRASS GIS 7 since r.in.gdal is much more powerful as pointed out in the harrikoo's comment. Additionally, please take a look at grasswiki.osgeo.org/wiki/Computational_region – markusN Nov 1 '14 at 18:53
4

First, you could try to find out whether the map was imported or not: use the g.list tool for that (GUI: File -> Manage maps and volumes -> List). Sometimes the GRASS modules add an imported map to the layer tree even though the import was unsuccesful and consequently the map is not there, resulting in the error message you refer to.

Second, if the map was not imported, you could try to import it using r.in.gdal, which supports a larger variety of map types. (GUI: File -> Import raster data -> Common import formats)

  • Thank you very much. I solved my problem by installing Grass 6.4.4. which works perfectly. – geof Nov 2 '14 at 10:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.