2

I am trying to overlay a raster Landsat 8 scene and vector scene boundary. Both are using WGS 84 + UTM48N. However, the vector (orange line) appears offset when overlaid on the raster. I have checked and confirmed that both layers have the same CRS (EPSG:32648), which is also being used by the QGIS map project.

enter image description here

A similar issue has been brought up before, e.g. here, which noted a bug, but nearly two years later I assume this is now solved.

Anyone else experiencing this and can confirm if it is a bug or a user error?

7
  • Have you tried reprojecting the raster (Raster > Projections > Warp (Reproject) with the same CRS?
    – Joseph
    Oct 28 '14 at 12:58
  • The other case you mention was about different towgs84 parametersets. This should have nothing to do with WGS84 UTM imagery which has alwasy towgs84=0. Are you complaining about the black parts, or should the yellow polygon fit to the image?
    – AndreJ
    Oct 28 '14 at 15:35
  • @Joseph, I just used GDAL to warp to the same CRS again, but this appears to have no effect. I also removed the black no data areas of the image to make it clearer. The orange line does not need to fit the extent of the image exactly, since there is supposed to be a buffer/overlap with adjacent scenes. The issue is that I assume the raster and vector should have parallel boundaries, but do not.
    – Dan
    Oct 28 '14 at 16:34
  • What data did you use to build the polygon?
    – AndreJ
    Oct 28 '14 at 16:56
  • The polygon was downloaded direct from USGS/NASA in WGS84 and represents a descending (day time) scene boundary. I selected one polygon as a test and saved it to UTM48N, using QGIS.
    – Dan
    Oct 28 '14 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.