I've made this model, to assess some 500-600 rasters for one area, and spit out one huge table. So far, when testing it with 20-30 rasters as inputs it works, but now that I put in the full amount its taking hours. It appears that it's getting hung up on the merge tool. I thought that the collect values tool would hold the individual tables, and then as a last step merge them together, but it seems like that is not the case (?). Does anyone have any ideas about how to make this more efficient?enter image description here


1 Answer 1


You have made the classic mistake that people do when they start using an iterator. EVERYTHING runs in a model that has an iterator. So everything up to and including the collects tool must be in a sub model. Expose the collects tool as a parameter. Then drag that model into the master model which has the merge tool. Connect your output from your sub model to the merge tool. Then the merge tool runs only one as it should. As you have it the merge tool is running with every loop of the iterator which makes no sense and is highly inefficient.

Have a look at my answer on this thread. Ignore the original poster as he still gets it wrong although his "worked" but I suspect its because he had few datasets to process.

  • +1 Good advice. It would be worthwhile to use the "collect values" tool within a submodel and then feed that list of inputs into the merge tool
    – Aaron
    Oct 29, 2014 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.