Running GRASS 6.4.3 within QGIS 2.4.0 on Mac OS 10.10 Yosemite. I'm trying to run v.net.iso within the GRASS shell, but the following error is returned every time:

bash: v.net.iso: command not found

I did this successfully two weeks ago before I upgraded to Yosemite, but have not been able to get it work since. I've tried a number of other commands in the shell module, and I get the same error each time.

  • 1
    Please add the output of "g.version -g" (best is that you edit your questions) – markusN Nov 1 '14 at 19:07

There is something wrong with the Shell where it does not load the Grass /bin into $PATH My solution is to do it manually inside the Shell.

$ echo $PATH

$ PATH="/Applications/QGIS.app/Contents/MacOS/grass/bin:$PATH"
$ export PATH
$ echo $PATH
| improve this answer | |

I'm also on OSX Yosemite using QGIS and GRASS, the GRASS shell in QGIS doesn't start, but it's hard to use anyways (It's hard to copy-paste, the font is hard to read and there is no cursor or command history).

I start GRASS in the OSX Terminal, doing all analysis there, while I use GRASS in QGIS to export shapefiles into the GRASS database, and to load them back into QGIS, without problems of a locked GRASS server.

In Terminal start GRASS using

$ Applications/QGIS.app/Contents/MacOS/grass/grass.sh

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.