I want to be able to view and edit spatial data within a postgis database. I have tried using a WFS with Geoserver - but constantly get 'Empty Response' error and the Network log says the request timed out. However it renders great.

I load the same dataset directly from postgis and I can edit, update and delete no problems.....but it renders HORRENDOUSLY slow (only 115 polygons in the dataset at this stage), to the point where panning around the map is totally impractical for day to day use.

I can also display/edit/update/delete fine, with great panning ability (I assume it is cached or turned into a .lyr file) using ST-Links in ArcGIS.

The fact that the same dataset can be displayed and edited using two different methods indicates to me that the database is fine, and that either the settings/bugs in QGIS are causing an issue - or is there something in Geoserver that may be influencing the inability to edit WFS?

NOTE: The QGIS option for the database 'Use estimated table metadata' is checked and made no difference. 'Use render caching' in the rendering options is checked and made no difference

Can anyone suggest some known issues/areas to troubleshoot to get this fixed - even to stop QGIS from constantly re-requesting data each time I pan would be great!

  • 1
    By default QGIS does not constantly re-request data unless the check box from "Cache Feature" has been unchecked. Which version do you have and have you changes the default value of the "Cache Feature"? Genarally speaking slow response must have something to do with your environment. I do not mean that you are doing anything wrong but PostGIS layers usually render very fast and I believe they will for you too once the bottle neck is found.
    – user30184
    Commented Oct 29, 2014 at 11:54
  • I have tried using 2.0 and 2.4 - I can't see any caching options other than 'Use render caching where possible to speed up redraws. Also trying to view the attribute table is a nightmare. Scrolls so slowly! Are there any tests or other options I can use to try and troubleshoot the source?
    – lolcat
    Commented Oct 29, 2014 at 20:58
  • I mean the "Cache Feature" box as in this image from the QGIS manual documentation.qgis.org/2.0/de/_images/connection_wfs.png
    – user30184
    Commented Oct 29, 2014 at 22:55
  • Oh yes, that is checked, and that is probably why the WFS works well when panning etc. I think i'll just have to change the workflow when editing data to convert the PostGIS data to offline - do the edits etc then sync back to the database.
    – lolcat
    Commented Oct 29, 2014 at 23:11
  • Ok, I misunderstood that you talked about requesting data from WFS. With PostGIS that should not be any trouble and table with 115 polygons is just nothing but I can't imagine what might be broken. Perhaps you should enable SQL statement logging in your PostgreSQL and re-run the queries from the log manually. Perhaps you will find which queries are so awfully slow for you.
    – user30184
    Commented Oct 30, 2014 at 5:30


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.