4

I'm working on deploying QGIS 2.4 into a XenApp 6.5 desktop environment.

We've tested QGIS to see if it will run in our environment on a test server and have found that building Pyramids with aerial photos for a map causes the user's session to grab as much memory as it wants. is there either a way to limit the memory a session can grab, or disable the building Pyramid feature?

We load balancing our XenApp environment, we have 2 different memory configurations running in this farm, we have 48GB and 32GB servers. If we ended up with 2 QGIS users on 1 32GB server and 1 of them ran the Build Pyramid command, it could potentially cause the server to fall over.

Apologies if this is the wrong place to post. Please point me in the right direction if that's the case.

  • Why not to pre-process the Ariel photos and build pyramids with gdaladdo beforehand? – user30184 Oct 29 '14 at 12:29
  • Thanks for the response Joseph. I do not use the application itself, I am the IT guy tasked with installing it. We've found that when processing all the Ariel photo's at once, it causing large memory grabs which could knock out a server & all its users. To ensure this doesn't happen I'd like to remove the setting from the menu's. I've gone through and removed some of the menu options, however, this is on the properties of the Image & under the Raster toolbar menu, I'd rather remove the option to build the pyramids so we can avoid it being used by mistake. – Lee Nov 5 '14 at 14:06
  • QGIS will work much better if images have the overviews. The right thing to do is not to prevent users from creating overviews but to create overview beforehand so that users will never need to create them. Just create overviews in such way that your server will not get jammed. I suggest to create overviews on another computer and copy images to the production server after that and you will all be happy. – user30184 Nov 5 '14 at 14:37
  • Thanks user30184. I believe this is how large renders will be managed. I still need to prevent this from happening with-in a Citrix Environment, simply down to the impact this be cause if it was run by mistake, by taking the tools away we know it'll never happen. I've removed the layer properties option from the Layer menu (This was done by setting the registry setting against "mActionLayerProperties" to "false" in the Windows registry). I now need to get the same properties window option out of the contextual menu when you right click on an image, any ideas? – Lee Nov 10 '14 at 14:50
1

I have deployed the very same architecture in XenApp + QGIS 2.4. If you digg into QGIS and associated tools, you will find tons of tools that can use all the resources of your virtual servers. I don't think it is possible to disable them all, because users will probably need them, on reasonable datasets. What I do is have big raster data on readonly file servers, so that a user can't do such tasks, or only if he did copy (120 Go.. you need to really want it). To avoid users digging such high level tools, we deploy prestyled data thanks to "layer's menu from project" plugin, so that common users almost never have to open layer properties, except for style and labeling work. It's been running for 3 years now, and only a few cases occured with QGIS grabbing the memory and CPU, and that was more caused by qgis issues when digitizing or stupid sql queries with no join clause.. If you really want to avoid pyramids, you should probably serve the data through WMS (with qgis server, geoserver or mapserver) or ecw/jp2 format (already build with pyramids). Cheers Régis

1

From the gdaladdo help page, use -clean to remove all overviews (a.k.a. "pyramids"). The option is available from GDAL 1.7.0. So, from a shell:

$ gdaladdo -clean myfile.tif

However, note that for internal GeoTIFF overviews (or external overviews in GeoTIFF format), -clean does not shrink the file.

  • The OP does not want to remove the pyramids from the image but rather remove the option of creating them. – Techie_Gus Mar 13 '17 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.