7

I have a fresh install of QGIS 2.4. When trying to open a .shp file I get the error message below.

I've followed their advice and have done several re-installs and also cleared all qgis files from my system (Parallels on Mac OS X 10.6) before those re-installs. I've tried QGIS 2.2 which caused the same problem.

Funnily all worked for a day, the following day and since not anymore...

Has anyone come across this before?

qgis_core

  • Just did a fresh install of 2.10.1 (32 bit) on Windows and it has the same problem when running bin\qgis-bin.exe – Kwebble Aug 29 '15 at 14:16
  • After installation I open it but the response was..I have a missing (qgis.app.dll) so I need to reinstall. – Nelson Taingol Apr 11 at 5:39
6

I also receive the same when opening .shp files directly and selecting qgis-bin as the program to use. But I always load QGIS via the Desktop icon. I'm not exactly sure why but my guess is that the Desktop icon simultaneously runs the following 2 files in order to load QGIS (this is the Target which you can see in the icon's properties):

"C:\Program Files\QGIS Valmiera\bin\nircmd.exe" exec hide C:\PROGRA~1\QGISVA~1\bin\qgis.bat

My advice is to load QGIS via the Desktop icon (usually has a name like "QGIS Desktop 2.4.0") and then drag/drop your shapefile that way.

Edit:

As Steve has already found out, it's possible to drag your shapefile to the "qgis.bat" file which will load QGIS and the shapefile itself.

  • Joseph, this works here! I've now also re-mapped .shp files directly to the qgis.bat so that I can click them directly. – Steve222 Oct 30 '14 at 12:23
  • Brilliant! You just taught me something also :) – Joseph Oct 30 '14 at 12:27
  • Mapping the shapefile to QGIS is awesome. – Branco Oct 30 '14 at 12:38
  • @Branco, certainly is buddy! Only been 9 months since I first started using GIS software of any kind (I chose QGIS) and still there's masses of things for me to learn :) – Joseph Oct 30 '14 at 12:41
2

I had this issue recently. None of the answers here worked to me.

When I use QGIS 2.4, I usually work with my laptop plugged in a bigger lcd monitor. Then, I project everything in the second monitor using a hdmi adapater. So, when I turned off the second monitor, QGIS started to show the message 'qgis_core.dll missing'.

To fix, I pressed the key 'Fn + F1' (Dell laptop) and choose the first option to project images only to the first monitor. Than, the QGIS worked again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.