2

I have set up Mapnik with mod_tile and renderd. I replaced the default osm.xml file with my own xml file, which is shown below.

My problem is that all images are being created as solid blue tiles as per the #8db0d3 background-color param in the xml file. I can change that, and the tiles will change their colors, so I know that the setup is paying attention to the xml file.

What do I need to do to make Mapnik render tiles for the specified Layer according to the given Style, and not just as a default solid background color? I expect solid-color tiles for most of the world, just not for the small area along the Connecticut coast that the given image details.

I feel like it might have something to do with the srs parameter to the map and/or layer, but I am not sure.

I can run a python script using this xml file and the output image is colored appropriately, so it would seem to be something to do with the interaction with renderd/mod_tile

Also, for what it's worth, I do not have any OSM data downloaded...though I wouldn't think that would stop it from working.

<Map srs="+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0.0 +k=1.0 +units=m +nadgrids=@null +wktext +no_defs +over" background-color="#8db0d3" maximum-extent="-20037508.34,-20037508.34,20037508.34,20037508.34">
  <Style name="DISCRETE RAINBOW">
    <Rule>
      <RasterSymbolizer>
        <RasterColorizer default-mode="discrete" default-color="yellow" >
            <stop color="red"    value = "0"  />
            <stop color="orange" value = "5"  />
            <stop color="yellow" value = "10" />
            <stop color="green"  value = "15" />
            <stop color="blue"   value = "20" />
            <stop color="indigo" value = "25" />
        </RasterColorizer>
      </RasterSymbolizer>
    </Rule>
  </Style>

  <Layer name="dataraster" srs="+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0.0 +k=1.0 +units=m +nadgrids=@null +wktext +no_defs +over">
      <StyleName>DISCRETE RAINBOW</StyleName>
      <Datasource>
          <Parameter name="file">/data/srtm/n41w073.hgt</Parameter>
          <Parameter name="type">gdal</Parameter>
          <Parameter name="band">1</Parameter>
      </Datasource>
  </Layer>

</Map>
2

In case anyone is interested, the problem above was a simple error on my part - the srs for the Layer was incorrect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.