3

I have a strange issue. Editing a layer with node tool I get always the following message: "Node tool: could not snap to a segment on the current layer." This error happens to me even with a fresh install of new 2.6 version only on my xp system (erased .qgis directory in profile and with no plugin at all) I get this error in all the currently installed release (2.0, 2.2, 2.4, 2.5 weekly, 2.6) and appears to be system dependant as other xp systems near to me are not affected. What can I do?

screen
(source: nabble.com)

  • Is the Default snap mode (Settings > Options... > Digitizing) set to To vertex and segment? – Joseph Nov 3 '14 at 12:01
  • Make sure some value for snapping tolerance is set too, should be same digitizing menu in previous comment. This controls how close before the feature will snap to another without it snapping won't work – user33290 Nov 3 '14 at 13:57
2

I Think its important to add the first step to the above response, which is correct, but missed the first step (settings): ->Settings -> Options -> Digitizing -> Snapping. Also, the above solution worked best for me when changing the units to "map units" instead of "pixels" - I don't have that great of dexterity.

I really appreciate the above response but seeing as many of us are googling this as we go (i.e. learning to use QGIS, or learning to use the newest version - which happens about once a month) it is nice to have the complete sequence.

1

I found the solution.... The parameter in Options|Digitizing|Snapping "Search radius for vertex edits" has to be non zero... With zero value Node tool gives the reported message.

optionsDialog
(source: nabble.com)

-1

this is the solution, go to Project / Assembly options / click on the first-left cell. In Cast es Ir al Proyecto / Opciones de Autoensamblado / click en la primera celda de la izquierda.

  • Welcome to GIS SE. AS a new user, please take the Tour to get accustomed with the rules of this board; most importantly, to reach a worldwide audience the working language on all related sites is English, and that should include software specific terms, menu navigation and settings/options. Consider formatting your text for a better appeal and readability. Finally, this is a very old post, using outdated software and any issue/solution can very well be obsolete: at least add your specific software setup/version for reference. – ThingumaBob Jun 7 '18 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.