in Qgis 2.6, in Map composer, while selecting grid frame style as Zebra, it does not works. Also while drawing coordinates points as exterior in map convas, it is not displayed. Actually I am facing this problem in Mac OS. while composing a Map, the Grid and coordinates are not displayed, but when I export/ save as the map canvas in as JPEG/PDF, the Grid and coordinates is displayed in output.

3 Answers 3


The zebra style and coordinates work correctly in QGIS 2.6. Zebra style is dependent on the grid interval. To see the zebra effect you must first define a suitable interval in the units of your CRS. When you first create the frame the interval is zero and so no zebra-effect will be shown. Likewise for the coordinates. Until you define an interval, they will not appear because they too are dependent on the size of the interval.

EDIT: Additional detail enter image description here

To see and control the zebra effect you need to:

  1. set a suitable scale
  2. add a grid using the green plus sign
  3. Set the grid interval. The interval defaults to map units but can be in mm or cm. This is where QGIS controls the grid interval and thereby the zebra interval. If you are using map/CRS units for the grid, then thezebra is altered by the combination of scale (step 1) AND interval (step 3).
  4. select the zebra grid style.
  • Can you clarify this comment? I'm having the same problem. Where exactly is QGIS pulling the zebra interval?
    – Justin
    Dec 19, 2014 at 23:17
  • @Justin, please see my edits above. Dec 20, 2014 at 16:12
  • 1
    Thanks for the updated response. I followed your example, but it still didn't work. But, then I ran QGIS in Ubuntu and the zebra grid worked just fine. I'm running Mac OS Yosemite. So, maybe it's the OS?
    – Justin
    Dec 21, 2014 at 21:06
  • I'm on Windows 7 64bit and all's well so maybe you're right. Try reinstalling Dec 21, 2014 at 21:31
  • I compiled QGIS 2.6 from sources on Linux and I have the same problem. I did not have this issue in 2.4. I believe that it is a bug somewhere that shows in certain circumstances.
    – Bogdan
    Dec 29, 2014 at 15:33

I believe it to be a bug. I had the exact same problem with Mac OS 10.9 and 10.10. I loaded Ubuntu in Virtual Box and the linux version of QGIS did not have this problem.


It is a bug, at least on Linux. I compiled the 2.6.1 version and my I could not get zebra or the coordinates displayed. It may be that the project was created with version 2.4. I will have to test that.

However, when I reverted the GIT checkout to final_2_4_0 and recompiled the zebra frame and the coordinates work just fine.

I can see here 2 possibilities: 1) incompatibility at the Composer level between 2.4 and 2.6,(because I discovered other issues with map rendering) 2) a serious bug in 2.6 and 2.6.1 for certain configurations

There is a bug report here in their database related to that that seems to be fixed but may have resurfaced:

I will be able to try the first option since I can build both versions.

Not the answer you're looking for? Browse other questions tagged or ask your own question.