1

I am having a few issues with a join to a File GDB from an Excel .xls file I imported as a table to the FGDB.

The problem being records that are in the original spreadsheet are not appearing in the imported table and when I join and keep all records I am getting null values although I know in the original spreadsheet the values exist. There about 65000 records in the spreadsheet.

I have also tried with a CSV and failed as well as changing integer and double in the field type - can't seem to work out why this is.

The join is one to one, so nothing complex about it at all.

I'm using ArcGIS 10.2.2 for Desktop.

  • Microsoft Excel 2003 (xls) and before had a maximum of 65535 rows. dbf files can have many more but are limited to 2GB, Access (.mdb) is also limited to 2GB total size. Most likely your import flaked out... generally I use Access to import Excel (.xls and .xlsx) to personal geodatabase table which works much better; the Excel to Table tool indicated by PolyGeo is slightly more robust if you don't have MS Access. For larger CSV files (more than 4GB) I import using python file access and insert cursor - each script is custom to a single file import operation. – Michael Stimson Nov 5 '14 at 1:50
  • thanks I had forgotten about xls only using 65K rows and the rest of the info !! – Leith Hawkins Nov 5 '14 at 2:35
1

You may try to first import into Access (Personal Geodatabase) then export them to your File Geodatabase, Excel is not very suitable to handle large records. For null values in your spreadsheet if numeric replace them with 0, it tend to solve the problem when joining, just make sure your join is on similar type fields (string to string, integer to integer etc)

2

I recommend taking a step back from the join, and first work out why not all rows are in the table that you created from your Excel file.

Try using the Excel To Table (Conversion) tool which:

Converts Microsoft Excel files into a table.

to do this.

  • thanks Ill give it a whirl !! As I said I had forgotten about he 65 k rows :D Leith – Leith Hawkins Nov 5 '14 at 2:36
0

In the end I re exported the output to CSV and and imported using the table to table import and it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.