4

I'm just discovering QGIS so please excuse my ignorance! I have QGIS 2.4.0 installed, and am trying to install Ordnance Survey Mastermap data. I have installed the OS2OGR translator to handle the decompression of the .GZ files, but the plugin manager reports the plugin is "broken - missing metadata file." I have checked the plugin folder, and the metadata file is there - what am I missing?

  • Did you download and install this from the QGIS interface (Plugins > Manage and Install Plugins... >? The plugin is called "Ordnance Survey Translator", this may have been renamed from OS2OGR. I have just downloaded and tested this and it loads up fine. – Joseph Nov 5 '14 at 10:22
  • Unfortunately due to "Security" protocols at work, the Plugin interface doesn't work, and IT won't release details of the Proxy Server, so I manually downloaded and added the plugin as detailed in other similar questions on the site. – Dave Phillips Nov 5 '14 at 10:28
4

You can manually download your Ordnance Survey Translator plugin from the repository and extract the folder to the following directory:

C:\Users\(your user name)\.qgis2\python\plugins\

Restart QGIS and from the toolbar, go to Plugins > Manage and Install Plugins...

Your plugin should be listed, check the box next to the plugin name to enable it.

  • 3
    Make sure to obey the folder structure. It might be possible that you extracted the plugin as a folder named C:\Users\yourname\.qgis2\python\plugins\os2ogr\os2ogr which is one folder too much. – AndreJ Nov 5 '14 at 16:32
  • 1
    Thanks @AndreJ, very good point and an easy mistake to make (happened to me a couple of times!) – Joseph Nov 5 '14 at 16:34
3

@AndreJ:s comment on another answer solved the issue for me, thought it would be good to add it as a possible answer. If not, please let me know.

Make sure to obey the folder structure. It might be possible that you extracted the plugin as a folder named

C:\Users\yourname\.qgis2\python\plugins\my_plugin\my_plugin 

which is one folder too much.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.