2

I've got a QGIS project with several layers with SRC EPSG·4326 - WGS84. I have downloaded from a government website a layer projected in ETRS89. I have tried my very best to match this new layer with those of the project, without any success. Changing CRS or activating "on the fly CRS transformation" do not solve the problem.

Copy-paste of extent. First, layer correctly placed. Second, problem layer (in Spanish, sorry!)

Extensión
En unidades del sistema de referencia espacial de la capa
xMín,yMín 387849.41,4137256.07 : xMáx,yMáx 549392.49,4264982.51
Sistema de referencia espacial de la capa
+proj=longlat +datum=WGS84 +no_defs

Extensión
En unidades del sistema de referencia espacial de la capa
xMín,yMín -9.52083,35.1667 : xMáx,yMáx 4.47917,43.8333
Sistema de referencia espacial de la capa
+proj=longlat +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +no_defs
7
  • usually ETRS89 is the datum associated with a specific projecion in Europe, most likely Lambert azimuthal equal area or Lambert Conformal Conic. Have you tried those ? Can you give the values of a couple of coordinates that are supposed to match ?
    – radouxju
    Nov 5, 2014 at 19:13
  • Can you add the extent of the layers, as reported by Properties, Metadata tab?
    – AndreJ
    Nov 5, 2014 at 19:13
  • Lambert projection doesn't seem to work.
    – jpinilla
    Nov 5, 2014 at 19:30
  • Use this fine site and try to find a right EPSG code for your data projfinder.com Feed in xmin ymin coordinates 387849.41,4137256.07 and from the map on the right side show the place where your data are from.
    – user30184
    Nov 5, 2014 at 19:36
  • changing CRS to those provided by projfinder.com do not solve the problem.
    – jpinilla
    Nov 5, 2014 at 19:59

1 Answer 1

2

The first layer is definitely not WGS84 longlat, but something projected like UTM or other systems used in Spain. The second one might be correct.

I imported the extents as delimited text, setting WGS84-UTM 30N EPSG:32630 for the large ones (in green) and WGS84 EPSG:4326 for the small ones in red, On-the-fly-reprojection activated. Project CRS is set to EPSG:3857 to add an OpenStreetMap background from the Openlayers plugin:

enter image description here

You have to use Rightclick -> Set CRS for Layer on the first layer to get the right CRS. Reprojecting is not a good idea, because the coordinates are in another (wrong) CRS than is specified for the layer.

2
  • Thank you very much for your help, but I don't understand. I have set both CRS as you mentioned above and the large layer does not appear. Sorry for causing so much trouble.
    – jpinilla
    Nov 5, 2014 at 20:30
  • Sometimes it just needs to force a redraw to get the layers together. Perhaps you should start a new project from scratch, adding first the Openlayers background, then the file in latlong, then the UTM file.
    – AndreJ
    Nov 6, 2014 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.