I am having an issue with the SAGA cluster analysis for grids tool within QGIS 2.4. I am actually taking this as an online class through Del Mar and we are going over supervised and unsupervised classifications of aerial imagery.

I have my CRS set as EPSG 32616 for the shapefile I want to classify, however, when using the tool I keep getting an error that the CRS is undefined and it defaults to 4326.

On top of that, the resulting output is upside-down. When looking in the layer properties the CRS is 32616 for the Clusters but the Statistics table is defined as 4326. My Project Properties are set to on the fly and I set the CRS as 32616. I have attached an image of the issue as well.

Anyone know what may be causing this to happen?

I have gone through this 3 or 4 times with the same result.



SAGA is an external tool, so it does not know what you have set for layer or project CRS inside QGIS.

You have to apply the CRS to raster files using Raster -> Projections -> Assing projection using gdalwarp -t_srs or Raster -> Conversion -> Translateusing gdal_translate -a_srs to another filename, and run SAGA on that.

  • Thanks for that AndreJ. I will give that a shot this evening. Would this also cause the output file to be rotated upside-down? I could understand it being in a different location, but not with a different orientation all together. – fringearch Nov 6 '14 at 11:50
  • With proper georeferencing information, it should not get rotated. – AndreJ Nov 6 '14 at 12:28
  • I did as you had suggested and still end up with the same result. I have tried to set the project properties to use CRS 32616 and then load all the data as well as checked the layer properties. Even though it says the default 4326 was used, the layer and project properties still indicate the crs as being 32616. – fringearch Nov 7 '14 at 2:39
  • Can you run gdalsrsinfo on the raster file? If that fails, try gdalinfo. Or upload the file to dropbox or similar. – AndreJ Nov 7 '14 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.