3

I need to transform a DEM from a Point-Feature-Class (Shape) to raster (GRID). For that I'm using the tool 'point to raster' and it works perfectly.

The only problem is that it seems to change the coordinate system, so that my resulting GRID has another system than my Shape.

The Shape has DHDN_3_Degree_Gauss_Zone_3 (which I want to keep), but the resulting GRID has Deutsches_Hauptdreiecksnetz_Transverse_Mercator.

Can anyone tell me why that is and how I can prevent it?

Or is there any way to transform the Transverse_Mercator-system back to Gauss?

I fill in the tool dialog as follows: input features: my point FC which has the DHDN_3_Degree_Gauss_Zone_3 CS value field: my z-values (height of the DEM) output raster dataset: destination folder cell assignment: mean priority: none cellsize: 1 and set the output coordinate system to 'same as input' in the environments settings.

  • 3
    Where is it getting it to the coordinate system from? Is it your data frame? Check also your "Environments" settings, there may be something in there. You can always project the result back, but I'm more interested in why you have to do that. I would expect the coordinate system to be the same as the input. – jbchurchill Nov 6 '14 at 13:59
  • 1
    I second checking your Output Coordinates setting under your Environments tab. The default is to be the same as the input. Also double check the coordinate system for your point FC. – user23715 Nov 6 '14 at 21:22
2

As commented by @jbchurchill and @user23715, I recommend checking your Output Coordinates setting under your Environments tab to see what it is set to.

I/we do this because in the Point To Raster (Conversion) help it lists the Environments respected by that tool as being:

Environments

Compression, Current Workspace, Output Coordinate System, Extent, Pyramid, Scratch Workspace, Cell Size, Snap Raster

Following the Output Coordinate System link you will see that:

This specifies the output features coordinate system of geodatasets created by geoprocessing tools.

  • Same As Input—The output geodataset will have the same coordinate system as the input. This is the default.
  • As Specified Below—Choose the coordinate system for output geodatasets. Specify a coordinate system name or browse using the Spatial Reference Properties dialog box.
  • Same as Display—In ArcMap, ArcScene, or ArcGlobe, the coordinate system of the current display will be used.
  • Same as Layer —All layers are listed, and you can choose one as the coordinate system. Like the Same as Display option, the coordinate system of the layer is read and stored. The next time you examine the Output Coordinate System setting, it will read As Specified Below.

Your result suggests that you have this set to other than Same As Input.

  • My data frame has the (desired) coordinate system DHDN_3_Degree_Gauss_Zone_3, as well as my output FC. The output coordinate system in the environments is set to 'same as input'. Even though, my output GRID continues to have the Deutsches_Hauptdreiecksnetz_Transverse_Mercator as space reference... – chris3o12 Nov 7 '14 at 7:02
  • Unfortunately I do not have the required licensing to test this. Perhaps you can edit your question to include the precise parameters that you are providing to the tool dialog. – PolyGeo Nov 7 '14 at 7:28
0

So over the weekend I found that my coordinate system stays constant if I output the raster to a TIF instead of GRID.

I don't know if I can work all the Spatial Analyst tools with a TIF as well, so will have to try and see which format works better for me...

Thank you for your help! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.