0

I have a tool which has input is an osm file, I ussually get the osm file by exporting map data from http://openstreetmap.org.

But now I have to get only data of roads so I use this query http://overpass-turbo.eu/s/2vM and it show what I need.

My problem is when I select "Export" tab and chose jOSM option for exporting to osm file, the site show me pop up :

Remote control not found. :( Make sure JOSM is already running and properly configured.

I don't know how to configure JOSM properly. ( Very sorry because my english skill is not good enough)

1

In JOSM, click on the icon with the switches, then the remote icon on the left (above WMS/TMS)

There you can activate the remote control checkbox.

Your query is missing meta data, which is mandatory for JOSM. Auto-repair will insert <print mode="meta"/>.

Alternatively, change your Overpass query to <osm-script output="xml" timeout="25">.

Then you can click on the Data tab on the right, select all, copy to clipboard and load it in an empty text file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.