0

When trying to add a new field to a shapefile in ArcCatalog, I have been told to type the field name manually into the vacant column in the shapefile Properties> Fields tab. However, the system won't let me type in the row under the field name column. I type and nothing shows up.

10
  • Have you tried actually typing the field name? Sometimes Arc doesn't display the cursor in the field initially, so you think it's stopping you,but you can still type in it. This has tripped me up before.
    – recurvata
    Nov 7, 2014 at 18:03
  • Yes I'm trying to type the word 'area' in manually and nothing comes up. I have clicked on the blank column and the beginning of the row and nothing. (Sorry I'm a complete beginner)
    – Alicia154
    Nov 7, 2014 at 18:09
  • 1
    Make sure there are no locks on the shapefile. If you don't have an exclusive lock ArcCatalog greys out or disables some features.
    – Dowlers
    Nov 7, 2014 at 18:19
  • And by locks I mean make sure no other applications or users are using the shapefile. (sorry if this is obvious but you said you were new to GIS).
    – Dowlers
    Nov 7, 2014 at 18:21
  • Check the folder is not read only where the shapefile will go. if there is an error 'Failed to add one of the specified fields.' means it is read only.
    – Mapperz
    Nov 7, 2014 at 18:21

1 Answer 1

3

At the suggestion of Chris W I'll post the comments as an answer in case it helps others in the future.

Make sure that there are no other connections to the shapefile you are trying to change. Schema changes require and exclusive lock, which means no one except you can be looking at the shapefile and even then you must only be looking at the shapefile from one application. If you have both ArcMap and ArcCatlaog open and pointing to the shapefile this might prevent an exclusive lock.

Another approach is to try to add a filed through the table properties drop down. open the table part or the shapefile (look for a dropdown under the preview tab that says geography and change it to table) and then look for table options dropdown. From here there is an option to add a new field. The advantage of doing it this way is if there are existing locks it will tell you the names of the user creating the lock.

One other possible solution is Mapperz suggestion of ensuring that the shapefile is no read only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.