2

I get this error when undertaking in query in QGIS2.4 or QGIS2.6:

An error occurred when executing the query. The data provider said: OGR[3] error 1: Unrecognised field name Fire.isochrones_2002_BigDesert_21122002.OBJECTID.

All my field names are less than or equal to 8 characters.

Anyone got any ideas on how to fix this?

2

Here, "Fire.isochrones_2002_BigDesert_21122002.OBJECTID" is interpreted as a single field name. What are the different attributes? : Fire, isochrones_2002, OBJECTID? The problem is probably coming from the dots in the field name.

  • I had same error for ESRI file with a dot in the name. It worked after rename the datafiles. This bug is still present in QGIS2.8. Bug was reported in ogr in 2014 (trac.osgeo.org/gdal/ticket/5379), marked as corrected 3 months later, but is still an issue in QGIS to date. – kFly Dec 3 '17 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.