3

I am having trouble processing an image through the Unsupervised KMeans image classification in the OTB Toolbox of QGIS 2.4. I have a .tif image in the Input Image box and keep all the defaults.

When I run it, this error immediately shows up:

"Algorithm Unsupervised KMeans image classification starting... unsupported operand type(s) for +: 'NoneType' and 'str' See log for more details"

I have tried increasing the available RAM (Mb) option as well as saving the Output Image in a file rather than a temp. I am relatively new to QGIS so I apologize if I have overlooked anything simple. Can anyone shed light on this problem for me?

  • @WhiteboxDev Yes it is a multi-band image – jdreyno Nov 10 '14 at 14:15
1

jdreyno... Yes it seems you overlooked something really simple, as I did.
I had the same problem and found I did not install orpheo toolbox. In fact, you can install QGIS and activate all the tool providers even if you have not installed them.
If you work on Windows you can install QGIS with the OSGeo4W installer, and you will get all Saga, Orpheo and Grass installed and configured to use with QGIS.
If you are on Ubuntu you need to install them. I installed Orpheo Toolbox from the ubuntugis unstable repository and the error message does not show up any more.
The tool is working great.

Asier

-1

I've already answered on the otb-users mailing-list:

https://groups.google.com/forum/#!topic/otb-users/_Lrd1Gsyws0

I think there is an issue with the way that qgis handle some output parameters in QGIS.

  • 4
    Please add more context to your answer. Link only answers become defunct when the link does. – Aaron Nov 12 '14 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.