I'm new in QGIS and I'm trying to reclass a raster with reclassify grid values. I want to reclassify by table, however fixed table has only 3 rows and I need some more, but button to add is not activated.

Do you have any idea about how add more rows?

  • Welcome to GIS:SE! What QGIS version are you using? I am using 2.6 and when I run the "Reclassify grid values" plugin from the Processing Toolbox, I can add more rows by clicking on the "..." button on the right of the option which is enabled.
    – Joseph
    Nov 10, 2014 at 11:15
  • Strange...try disabling the Processing plugin from Plugins > Manage and install Plugins..., restart QGIS and enable the plugin again (ps: you can add comments underneath this question instead of posting it as an answer :) )
    – Joseph
    Nov 10, 2014 at 11:50
  • Thanks, for your reply. No it hasn't worked. The button is still disabled :-S
    – Samuel
    Nov 10, 2014 at 15:51

2 Answers 2


First make sure that processing plugin is activated. Go to plugins/install and manage plugins and look for processing. Make sure it is activated. It should look like this:

enter image description here

You must have a Processing menu. Choose toolbox. In the toolbox, go to the bottom and choose advanced interface. I think you are trying to use SAGA reclassifying tool. I personally prefer the GRASS reclassify tool. In order to work with this tool you must create a text file with the classification rules. It must be like this:

enter image description here

Once you have the classification rules file save it as a txt file. If you are using Windows you can create this file with Notepad. Now type r.reclass in the filter box as shown in the image and choose r.reclass.

enter image description here

Once you select r.reclass you must see this dialog box:

enter image description here

You must choose the input raster, the file that contains the classification rules and also the output file. That should do it.

  • Thanks for your reply, but this option gives me another problem. It says that output layer could not be open, althoug "GRASS seems to be correctly installed and configured".
    – Samuel
    Nov 10, 2014 at 15:53
  • Try to load the classified layer manually. That happens to me when I choose to "open the output file after running algorithm". I simply avoid this step and load tha later manually. Hope it helps Nov 10, 2014 at 19:26
  • @GerardoJimenez thank you for this- worked like a charm!!! Feb 25, 2016 at 20:05

Fast and Best way to reclassification Raster in Qgis 3.2, 3.4, 3.6 version:

  1. From 'Processing toolbox', on "Raster terrain analysis"; open "Slope" and then fill up the required parameter (just provide your raster as 'Elevation layer' as input, 'Z factor' Default: 1, after that, you will get slope raster.

  2. On "Raster analysis"; open "Reclassify by table" which Reclassifies a raster band by assigning new class values based on the ranges specified in a fixed table. And then fill up the required parameters. At first input your slope raster as 'Raster Layer', on 'Reclassification table' fill up it like below screenshot picture:

Reclassification table

Open "Show advanced parameter" and on 'Output no data value' let it Default: -9999.0000, on 'Range boundaries' select "min <= value < max" , on 'Use no data when no range matches' let it Default: no, on 'Output data type' which Defines the format of the output raster file, select "Int32". hit run to get the reclassified slope raster.

  1. I have made a Processing model as workflow, which can Reclassify 5 GB of DTM Raster at just 30 seconds, to download and use it please open the link below: https://drive.google.com/file/d/1Bl2N-BHoxApVkD_V8OmYCRR2olJOpUQy/view?usp=sharing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.