2

I use a DEM file (*.tif) and a points layer. My need is basic : getting the Z value for each point by extracting them from the DEM. Both layers correctly opened with QGIS 2.6. The DEM returns a Z value if I click with the « i » button (informations).

'Point Sampling Tool' plugin is set as below :

  • Layer containing sampling points : my points layer
  • Layers with fields/bands to get values from : I select my DEM, which appears in the list as : 'EUD_CP_DEMS_3500015000-AA-86 : Band 1 (raster)'
  • Output point vector layer : output.shp
  • Add created layer to the TOC : activated

The following message in still issued in the 'Status' part :

Complete the input fields and press OK...

I don't undertand what to do with this message. Anyway, I validate the dialog and get my output.shp added to the TOC properly... BUT the attributes column is empty (NULL values). I have the right number of lines matching the number of points in my source points layer.

I can't find any further help on the Web. Such clear tutorials do not show any difficulties.

Is my DEM format a possible issue?

  • Do your points and raster layers share the same CRS? I.e., do they still align when On-the-fly reprojection is turned off? – AndreJ Nov 10 '14 at 16:03
  • I have the same issue! My CRS are not the same and they are not aligned anymore when On-the-fly reprojection is turned off so I guess that it is the reason why it is not working. My raster layer has the CRS WGS 84 /UTM zone 33 S and the vector layer has the CRS WGS 84... the issue is that if I change the CRS of the vector layer in WGS 84 / UTM zone 33S too, it disappears from the map! I don't understand how it is possible... The CRS of the project is CRS WGS 84 / UTM zone 33 S as well. – Lauriane Feb 23 '17 at 13:51
2

You need to highlight all the attributes you want to appear in the output from the "Layers with fields/bands to get values from" list. If you have not clicked on 'EUD_CP_DEMS_3500015000-AA-86 : Band 1 (raster)' so that it is highlighted then you will get nothing. This is what the message:

Complete the input fields and press OK...

means (I think "select" would have been a better choice of instruction than "complete"). You can select many fields from many rasters and fields from polygons and your original points too. If you do not select any fields, you will get nothing out. HINT: you can rename the fields in the output by using the Fields tab.

  • Thanks @MappaGnosis! But I had well clicked on the raster file... Just tried again but still the same result. I've edited my post to specify that I had clicked this layer. – wiltomap Nov 10 '14 at 15:57
  • You must click on the fields in the dialog box and not the layer in the TOC. – MappaGnosis Nov 10 '14 at 16:03
  • That's what I did! – wiltomap Nov 10 '14 at 21:11
  • Do both your layers have the same CRS and, if so, what do you get if you select your raster layer in the TOC and use the query tool at one of the points? – MappaGnosis Nov 11 '14 at 7:20
  • CRS were different : raster was 3035 and shapefile was 3947... That was the problem! Thank you for your help. I therefore saved the raster as 3947 and it did work perfectly. – wiltomap Nov 14 '14 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.